EBSCO Resources

To use the resources NoveList and TopicSearch, your web browser must be one of the following:

  • Netscape 7.x (or higher);
  • Microsoft Internet Explorer 5.5 (or higher); or
  • Macintosh minimum requirements: Safari 1.2x or Netscape 7.x

The minimum browser requirements for EBSCO Text Only products are the following:

  • Netscape 4.0 (or higher);
  • Microsoft Internet Explorer 4.0 (or higher); or
  • Lynx 2.8 (or higher)

© Jacksonville Public Library, City of Jacksonville.
Page last updated: